Comunidad de diseño web y desarrollo en internet online

Ayuda con aplicacion web

Citar            
MensajeEscrito el 19 Jul 2012 07:21 pm
Buenas, normalmente desarrollo con ASP.NET WebForms, pero visto el éxito que está teniendo el MVC me estoy planteando el probarlo en mi próximo desarrollo. El caso es que con WebForms siempre he tenido claro si mi aplicación iba a funcionar en un hosting compartido o no, simplemente sabiendo la versión. Es decir, si trabajo con ASP.NET 4.0* necesito un hosting que soporte 4.0 Como tanto WebForms como MVC trabajan con el mismo Framework ASP.NET me gustaría saber si existe algún tipo de equivalencia o algo así con las versiones de ASP.NET. Por ejemplo, para poder ejecutar desarrollos MVC3 necesitas que el hosting soporte ASP.NET 4.0... O si además de eso el hosting tiene que tener también instaladas las ¿librerías? de MVC3, o si simplemente yo puede instalar esas librerías en mi propio proyecto, etc * No quiero empezar con MVC3 y luego enfrentarme a estos problemas, y empezar con MVC2 en este momento que está apunto de salir la 3 me parece absurdo. *

Por single

Claber

153 de clabLevel



 

firefox
Citar            
MensajeEscrito el 19 Jul 2012 08:11 pm

Por danmolo

36 de clabLevel



Genero:Masculino  

Indie Game Developer

chrome
Citar            
MensajeEscrito el 19 Jul 2012 08:13 pm
Lo mínimo que debe tener el hosting es soporte de ASP Net. 4 y para que corra la aplicación debes copiar algunas DLLs en la carpeta BIN por si acaso no tiene el MVC instalado.

Te recomiendo que mires este link:
http://www.tugberkugurlu.com/archive/deployment-of-asp-net-mvc-3-rc-2-application-on-a-shared-hosting-environment-without-begging-the-hosting-company

Saludos

@afssx

Por afssx

Claber

100 de clabLevel



Genero:Masculino  

chrome
Citar            
MensajeEscrito el 19 Jul 2012 08:21 pm

single escribió:

No quiero empezar con MVC3 y luego enfrentarme a estos problemas, y empezar con MVC2 en este momento que está apunto de salir la 3 me parece absurdo. *

Creo que refieres a que saldrá MVC4 porque el actual es MVC3. Puedes instalar las librerías de ASP MVC3 en el hosting pero si es imposible también se pueden "adjuntar" en el proyecto, explicación aquí

Por nbreath

23 de clabLevel



Genero:Masculino  

chrome
Citar            
MensajeEscrito el 02 Ago 2012 10:41 pm
Pero no deberia contener un Framework4 para llevar a cabo la aplicacion en ese caso?

Por single

Claber

153 de clabLevel



 

firefox

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.