Comunidad de diseño web y desarrollo en internet

boton para direccionar a una web page

Citar            
MensajeEscrito el 20 Sep 2007 02:15 pm
hola, necesito ayuda para resolver un problema k me da actionscript
tengo un boton que cuando pinchas en él debería direccionarte a una página web, pero me da este error : El bloque de declaración debe finalizar con '}'
on (press) {
y la orden que tiene el botón es la siguiente :
on (press){
getURL("http://www.blablalbla.com/page.htm;");
}

¿ qué estoy haciendo mal? no consigo arreglar el problema
gracias

Por bucles

2 de clabLevel



 

firefox
Citar            
MensajeEscrito el 20 Sep 2007 02:31 pm
te sobra un "punto y coma" (;) despues de "htm"

Por gabynufe

Claber

446 de clabLevel



 

México, D.F.

msie7
Citar            
MensajeEscrito el 20 Sep 2007 02:49 pm
ni quitandole el punto y coma, sigue sin funcionar no sé si es problema del flash player o qué pero llevo ya un buen rato.

no se si influirá que tengo este botón (simbolo) aplicado a varios objetos pero todos con direcciones diferentes.

:(

Por bucles

2 de clabLevel



 

firefox
Citar            
MensajeEscrito el 20 Sep 2007 02:55 pm
No es un problema de AS ni del player. Lo más probable es que te falte un "}" en algún lugar de tú código que no sea necesariamente ese. Busca en el resto del código a ver si te falta una llave de cierre.

Por The Fricky!

Presidente

6168 de clabLevel

3 tutoriales
8 articulos

Genero:Masculino   Bastard Operators From Hell Héroes

Piccola Venezia...

firefox
Citar            
MensajeEscrito el 24 May 2011 09:28 pm
mmmm.... si estas trabajando tu proyecto en ActionScript3.0 ni que te hagas loco va a funcionar por que ese codigo solo funciona en ActionScript2.0 :wink:
y este es el codigo que estas utilizando

on (press){
getURL("http://www.blablalbla.com/page.htm;");
}

eso esta mal redactado el codigo seria

on (press){
getURL("http://www.blablalbla.com/page.html");
}

espero que sea de ayuda...
ah y por sierto este es mi primer coment sucede que yo tenia tu mismo problema y estaba en 3.0 y con un codigo erroneo estaba utilizando on(release) :P jaja...

Por osmanny

1 de clabLevel



 

safari
Citar            
MensajeEscrito el 24 May 2011 11:04 pm

Código :

on (press)
{
getURL("http://www.blablalbla.com/page.htm;");
}


lo copie, lo pegue lo ejecute y anda al pelo.

pd: es el codigo que pusiste arriba, ANDA

The Fricky! debe tener razon... en otra parte esta el error... ¿el codigo lo pones en el boton?

Por PrimoSaviSan

56 de clabLevel



 

firefox

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.