Comunidad de diseño web y desarrollo en internet online

LoadMovie

Citar            
MensajeEscrito el 18 Ene 2009 12:49 pm
Hola soy Maria Lina necesito saber como hacer para que el SWF que cargo a traves de LoadMovie....quede al frente del SWF principal, el MC "vacio" lo he puesto en un layer arriba de todos los demas, intente posicionandolo con "mandar al frente" pero se sigue viendo la animacion que esta sobre el SWF o pagina principal. Que puedo hacer?
Mil gracias!!!!!! :love:

Por elgnomo

16 de clabLevel



 

msie7
Citar            
MensajeEscrito el 18 Ene 2009 02:40 pm
Depende de como tengas estructurado todo....

Miraté el manejo de profundidades en Flash.

Aunque sea un poco "chapuza", puede poner la propiedad _visible del clip de animación en flase.

Por esedeerre

132 de clabLevel



 

MadRid

opera
Citar            
MensajeEscrito el 19 Ene 2009 12:20 pm
Mira aca te mando la direccion para que la veas y me digas, no soy programadora asique se suavecito, jajaja, soy diseñadora en comunicacion visual.!!!! y siempre se me cruzan estos problemitas que me matan!!!
Mil gracias :love: Maria Lina

Por elgnomo

16 de clabLevel



 

msie7
Citar            
MensajeEscrito el 19 Ene 2009 12:21 pm

Por elgnomo

16 de clabLevel



 

msie7
Citar            
MensajeEscrito el 19 Ene 2009 12:23 pm

Por elgnomo

16 de clabLevel



 

msie7
Citar            
MensajeEscrito el 20 Ene 2009 06:48 pm
no puedo ver tu ejemplo, pero como estás llamando a tu swf? a través de: loadMovie("nombre.swf", mc_contenido);

Por furrisima

16 de clabLevel



 

Lima

firefox
Citar            
MensajeEscrito el 21 Ene 2009 12:42 am
hola, si aca pongo el script
on (release) {
loadMovie("servicios1.swf","vacio","post");
}

la cuestion es que el MC que son unas lucecitas que se encienden en una imagen de edificios, la imagen queda atras pero el MC que esta puesto encima de esa imagen, tambien queda delante del SWF que llamo.
fijate si podes verla http://www.manava.com.ar
Gracias!!!!

Por elgnomo

16 de clabLevel



 

msie7
Citar            
MensajeEscrito el 21 Ene 2009 01:11 am
quitale el post a tu codigo

Código ActionScript :

on (release) {
loadMovie("servicios1.swf","vacio");
}


te refieres a las lucecitas que se siguen viendo por encima cuando entras a las secciones?

Por nasho

Claber

908 de clabLevel

1 tutorial

Genero:Masculino  

Web Developer

firefox
Citar            
MensajeEscrito el 21 Ene 2009 08:24 pm
Quitándole el post debería estar bien, en todo caso pásame tu fla para ver en qué anda el problema.

Por furrisima

16 de clabLevel



 

Lima

firefox
Citar            
MensajeEscrito el 21 Ene 2009 08:58 pm
es cuestion de profundidades ;)


Código :

on (release) { 
     loadMovie("servicios1.swf","vacio"); 
     vacio.swapDepths(10000);
}


Primero que nada quitale lo del POST
Segundo, con swapDepths le decimos que nos pnga el swf cargado, en un nivel superior.
Prueba con esto y nos dices ;)

Por rolv

Claber

2000 de clabLevel

3 tutoriales

 

opera
Citar            
MensajeEscrito el 22 Ene 2009 12:52 pm
Espectacular ,si era eso, cuestion de de profundidades, pero pasa otra cosa ahora.Al ponerle el script: vacio.swapDepths(10000) cada vez que presionas un boton los SWF van quedando en el lugar no desaparecen al apretar otro boton, se van sumando los SWF. Cambie los numeros (10000) para darle diferentes profundidades (esto lo hice sin saber en realidad, capaz que el 10000 es algo fijo y no se toca) pero no hizo nada.
El fla. es un despelote voy a arreglarlo poninedoles bien los nombres a lo layer para que lo puedas entender, no soy prolija trabajando, el impulso de mi cerebro puede mas que el orden, jajaja.
Otra vez gracias!!

Por elgnomo

16 de clabLevel



 

msie7
Citar            
MensajeEscrito el 22 Ene 2009 06:14 pm

elgnomo escribió:

Espectacular ,si era eso, cuestion de de profundidades, pero pasa otra cosa ahora.Al ponerle el script: vacio.swapDepths(10000) cada vez que presionas un boton los SWF van quedando en el lugar no desaparecen al apretar otro boton, se van sumando los SWF. Cambie los numeros (10000) para darle diferentes profundidades (esto lo hice sin saber en realidad, capaz que el 10000 es algo fijo y no se toca) pero no hizo nada.
El fla. es un despelote voy a arreglarlo poninedoles bien los nombres a lo layer para que lo puedas entender, no soy prolija trabajando, el impulso de mi cerebro puede mas que el orden, jajaja.
Otra vez gracias!!


Ok,

1.- swapDepths

Ayuda inservible de Flash de sale al apretar F1 escribió:

public swapDepths(target:Object) : Void

Intercambia el apilamiento o nivel de profundidad (z-order), de este clip de película con el clip de película especificado por el parámetro target o con el clip de película que ocupa actualmente el nivel de profundidad especificado en el parámetro target. Ambos clips de película deben tener el mismo clip de película principal. El intercambio del nivel de profundidad de los clips de película provoca que un clip de película se sitúe delante o detrás del otro.

target:Object - Este parámetro puede tener una de las dos formas siguientes:


  • Un entero exclusivo que especifica la profundidad a la que debe colocarse el nuevo clip de película.
  • Una cadena que especifica la instancia de clip de película cuya profundidad se intercambiará con el clip de película al que se aplicará el método. Ambos clips de película deben tener el mismo clip de película principal.



Con esto quedará claro que puedes cambier ese 10000 a tu conveniencia ;) ;) :D :D

2.- Respecto a que no desaparece el swf anterior; es cierto, hay que descargar el anterior por las dudas y luego cargarel nuevo
Intenta con este código

Código :

on(press){
   vacio.loadMovie(""); // Importante, este descarga el contenido del clip 
}
on (release)
{
   loadMovie("obras.swf", "vacio");
   vacio.swapDepths(10000);
}


Pon ese on(press) como acción, a cada uno de tus botones.
Debe de funcionar correctamente. ^^


PS, por cierto pasate al foro de charla y presentante, en una chance que tengas ;) ;)
Asi entenderas el alto nivel de sarcasmo que tiene el foro jajajaja XD
Saludos

Por rolv

Claber

2000 de clabLevel

3 tutoriales

 

firefox
Citar            
MensajeEscrito el 22 Ene 2009 07:00 pm
Ok, estoy muy agradecida!! voy a ponerme a hacerlo esta noche y veo que onda. En cuanto pueda me presento en las charlas, besos!!!
Maria Lina :love:

Por elgnomo

16 de clabLevel



 

msie7
Citar            
MensajeEscrito el 24 Ene 2009 12:53 pm
Barbaro!!! funciono de mil maravillas jajajaja, besos y gracias!!!!! :love:
maria lina

Por elgnomo

16 de clabLevel



 

msie7

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.