Comunidad de diseño web y desarrollo en internet online

No me sirve el resultado de un tutorial ):

Citar            
MensajeEscrito el 23 Ago 2010 08:19 pm
(Disculpen si este tema no esta en la seccion apropiada, solo que no supe donde ponerlo porque tiene que ver con Flash, PHP y ActionScript.)

http://www.cristalab.com/tutoriales/enviar-correo-electronico-en-flash-usando-loadvars-c7l/

Hola hize este tutorial solo que modifique las variables para que se adapten a un sistema de invitaciones.
Entonces el usuario puede invitar a otros desde el SWF.



Como pueden comprobar (dar click en sugerir) el codigo dice que el e-mail se ha enviado, lo cual quiere decir que marcha bien.
Sin embargo el e-mail nunca llega ):

este es mi edit del codigo email.php

Código :

<?php
   $sendTo = $_POST["email"];
   $subject = "Tienes una invitacion para Erodia de" . $_POST["namez"];
   $headers = "Reply-To: [email protected]";
   $message = $_POST["namez"] . "te ha invitado a jugar Erodia. Descarga el juego desde http://www.Erodia.com.ar";
   mail($sendTo, $subject, $headers, $message);
   echo "estado=Mensaje enviado :D";
?>

namez es el input del nombre
email es el imput del correo


Otro error que tengo es que en la linea del mensaje enviado no aparecen muchos tipos de caracteres como la z, las mayusculas y otros signos de puntuacion. :S

Este es mi codigo ActionScript modificado

Código :

//Declaro las variables para enviar y para recibir
var envio_lv:LoadVars = new LoadVars();
var recibir_lv:LoadVars = new LoadVars();
//Función que envia el forumlario
function enviarMail() {
   envio_lv.namez = namez_txt.text;
   envio_lv.email = email_txt.text;
   envio_lv.sendAndLoad("email.php", recibir_lv, "POST");
   //Aqui ustedes pueden cambiar de form.php a form.asp dependiendo del servidor
   //que usen
}
//Función que procesa los datos recibidos del servidor
recibir_lv.onLoad = function(exito) {
   if (exito) {
      estado_txt.text = this.estado;
   } else {
      //Muestra un mensaje de error en negrita
      estado_txt.text = "Error en la aplicacion de correo";
   }
};


He probado de igual forma subiendo el ejemplo a mi hosting y configurandolo para que llegue a mi email, pero tampoco funciona.

Alguna sugerencia?
Les agradeceré :3

Por xLukzx

12 de clabLevel



 

firefox
Citar            
MensajeEscrito el 23 Ago 2010 08:26 pm
oh por cierto, al parecer el archivo da error al ser probado desde una web fuera del servidor.
por lo que aconsejo que lo prueben desde este enlace por favor.
http://animefall.260mb.com/erodia/banner.swf

gracias.

Por xLukzx

12 de clabLevel



 

firefox
Citar            
MensajeEscrito el 25 Ago 2010 03:01 am
Ayuda por favor ._.

Por xLukzx

12 de clabLevel



 

firefox
Citar            
MensajeEscrito el 25 Ago 2010 02:49 pm
Al presionar el boton, que codigo usas?

Por Quarterback

171 de clabLevel

1 tutorial

Genero:Masculino  

Santa Marta, Colombia

firefox
Citar            
MensajeEscrito el 25 Ago 2010 04:15 pm
Hola! :)
el codigo que uso es este. Creo que es el mismo dado en el tutorial :O

Código :

on (release) {
   estado_txt.text = "Enviando su correo ...";
   enviarMail();
}


saludos :]

Por xLukzx

12 de clabLevel



 

firefox
Citar            
MensajeEscrito el 01 Sep 2010 04:11 am
Porfa alguien me ayuda ??????????????????????
:/

Por xLukzx

12 de clabLevel



 

firefox
Citar            
MensajeEscrito el 01 Sep 2010 04:32 pm
pon

Código PHP :

$ok = mail($sendTo, $subject, $headers, $message);
if($ok) {
  echo "estado=Mensaje enviado :D" 
}else{
  echo "estado=No se envio :(";
}

Por nasho

Claber

908 de clabLevel

1 tutorial

Genero:Masculino  

Web Developer

firefox
Citar            
MensajeEscrito el 11 Sep 2010 06:25 pm
El formulario funciona correctamente.

Pero el e-mail nunca se envía x__x
ya probe tratando de enviar a varias cuentas de correo. Pueden probar tratando de enviarse a las suyas y verán. El e-mail no llega.
Hay algo que me haga falta configurar (???
Estaré muy agradecido por su capacitación-
Saludos ^^

Por xLukzx

12 de clabLevel



 

firefox
Citar            
MensajeEscrito el 11 Sep 2010 07:12 pm
Ya funcionó!
al parecer toma su tiempo en ejecutarse. Muchas gracias por toda la ayuda ^^
:D

Por xLukzx

12 de clabLevel



 

firefox

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.