Comunidad de diseño web y desarrollo en internet online

Problemas con el css de menu navegacion

Citar            
MensajeEscrito el 30 Mar 2017 02:20 pm
Tengo un menú de navegación con submenús hecho con bootstrap y aplicando mis propias clases los cuales despliego con jquery. La cosa es que en el index.html me va a la perfección.
Pero cuando me voy a otra pagina que no sea index, todo el jquery para desplegar me lo hace bien pero los estilos de las subpaginas no me los coge.

Se puede ver como en la vista previa dinámica de brackets me marca los submenús con lineas azules pero no me aplica los estilos. Las rutas son las mismas que tengo puestas en el index, he probado a poner otras distintas y nada, me sigue pasando lo mismo. ¿Se os ocurre de qué puede ser?

Muchas gracias!!

Por crespo1313

0 de clabLevel



 

chrome
Citar            
MensajeEscrito el 26 Ago 2017 10:12 am
Hola, ¿lo estas haciendo con javascript? si es así, te recomendaría hacerlo todo con css, ya que es más fácil y con javascript es más difícil mira el siguiente video:



Si con javascript no te sale puede ser que no lo tengas bien llamado, si la función del javascript está separado del documento html, tienes que llamarlo con script antes de </header> y si ya lo tienes, mira si lo llama bien.

Espero haberte ayudado :wink:

Por IVAN HEREDIA PLANAS

34 de clabLevel



Genero:Masculino  

Lo increíble, no es lo que ves, sino como es

chrome

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.