Comunidad de diseño web y desarrollo en internet online

Problemas con el formulario de envio de correo AQUI

Ir a página 1, 2, 3, 4, 5, 6, 7, 8, 9  Siguiente

Foros de discusión > Actionscript 1 y 2

Citar            
MensajeEscrito el 21 Mar 2004 05:08 pm
Esta es una recopilación de posts relacionados con problemas con el formulario de envio de correo por medio de LoadVars; por fvor, leelos atentamente y si tu pregunta no es respondida con ninguno de los posts, deja la pregunta EN ESTE HILO, no abras uno nuevo.



http://www.cristalab.com/foros/viewtopic.php?t=107

http://www.cristalab.com/foros/viewtopic.php?t=119

http://www.cristalab.com/foros/viewtopic.php?t=118

http://www.cristalab.com/foros/viewtopic.php?t=97

http://www.cristalab.com/foros/viewtopic.php?t=98

http://www.cristalab.com/foros/viewtopic.php?t=91

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 23 Mar 2004 03:45 am
Freddy en que servidor tienes alojado tu el formulario?



Es que lo he probado en iespana y no va y en brinkster tampoco.



Toy desesperao con lo formularios me traen loco

Por masa

1 de clabLevel



 

unknown
Citar            
MensajeEscrito el 23 Mar 2004 04:08 am
Pues en cristalab lo tengo yo , es un servidor pago el mio :lol:

y segun me han contado en iespana va bien, en tripod tambien, en miarroba tambien y en Brinkster y los de ASP NO

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 23 Mar 2004 03:26 pm
mas info de free hosting :



en paginafacil.com no hay servicio , con lo k no se puede.



en wwwpuntocom.com hay



Servidor SMTP: mail.wwwpuntocom.com

Servidor POP3: mail.wwwpuntocom.com



kon lo k teorikamente si se puede, aun no lo he provado.

Por Dailion

42 de clabLevel



 

unknown
Citar            
MensajeEscrito el 23 Mar 2004 04:13 pm
Una cosa es la configuración de la cuenta de correo para Outlook o Eudora para que los ISP puedan acceder a nuestras cuentas de correo, y otra muy distinta, que las funciones mail() para php y losCDONT esten instalados en el servidor que uses para poder enviarl emai.



Saludos !



JOHNMARTIN

Por JOHNMARTIN

Claber

1222 de clabLevel

4 tutoriales
4 articulos
2 ejemplos

Genero:Masculino  

||| BOGOTA COLOMBIA |||

unknown
Citar            
MensajeEscrito el 09 Jun 2004 01:22 pm
me he vuelto loco probando vuestros codigos php y asp sin exito. he contactado con telefonica.net, que es mi proveedor de servicios de pago y me comentan que solo funciona javascript.



se puede hacer lo mismo con javascript?

sabeis donde puedo conseguir un codigo similar en javascript?

estoy funcionando con MX profesional 2004, existe alguna manera de hacerlo directamente con alguno de sus nuevos componentes?



gracias de antemano



flip

Por flip_sp

18 de clabLevel



 

unknown
Citar            
MensajeEscrito el 09 Jun 2004 02:15 pm
La respuesta a tus 3 preguntas es

no, no y no



Veras, Telefonica tiene fama de tener un mal servicio tecnico al usuario comun y a ti, en este caso te han engañado.



No es que ellos soporten JavaScript, es que ellos sencillamente no soportan ningun lenguaje del lado del servidor, JavaScript es del lado del cliente y no depende del hosting



necesitas conseguir un espacio de hosting libre con soporte a PHP o ASP (como http://iespana.es/ ) porque la unica manera de hacer esto es con un lenguaje del lado del servidor.



La otra forma es que tu mismo instales un servidor en tu PC, pero eso trae mas complicaciones tecnicas

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 10 Jun 2004 09:25 am
muchas gracias freddie



el problema que tengo es que estoy condenado a trabajar con ellos.



a ver si puedes ayudarme a encontrar otra solucion. estoy haciendo la web para un restaurante, y el motivo de enviar por email era para hacer un sencillo sistema de reservas. confirmamos la reserva por telefono, por lo que no tiene que ser un sistema on-line.



mi pregunta es: existe alguna manera de descargar los datos de un formulario de flash a un fichero en un servidor como el mio?

de esa manera podria descargarlo diariamente y comprobar los contactos.



muchas gracias,

recuerdos desde somo-cantabria



flip

Por flip_sp

18 de clabLevel



 

unknown
Citar            
MensajeEscrito el 10 Jun 2004 09:31 am
tengo un problema con el tutorial, yo uso mx (sin 2004) y no tengo las componentes de imput text ni de text area. He intentao hacerlo con campos de texto pero no me funciona.

Habria alguna diferencia en el codigo?? O en alguna otra cosa??

gracias

Por mamen_mala

1 de clabLevel



 

unknown
Citar            
MensajeEscrito el 10 Jun 2004 03:38 pm
para mamen_mala; coloca tu pregunta en otro post por favor, no mezlces preguntas en un mismo mensaje



Para flip_sp; antes existia una manera haciendo bypass a un script de Melodysoft, pero ya no hay; asi que si no tienes un lenguaje de servidor, NO, no hay manera, lo siento

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 10 Jun 2004 05:04 pm

freddie® escribió:

Esta es una recopilación de posts relacionados con problemas con el formulario de envio de correo por medio de LoadVars; por fvor, leelos atentamente y si tu pregunta no es respondida con ninguno de los posts, deja la pregunta EN ESTE HILO, no abras uno nuevo.





Creo que este es el post donde se deben hacer las preguntas sobre el tutorial de envio de correo, por lo menos eso creo leer en tu primer post, asique no creo que esté mezclando los temas. Me parece q no has entendido bien lo que quería decir.

Pero bueno, ya no necesito ayuda, pq he encontrao otra forma de enviar los formularios usando flash mx, sin componentes, y que funciona

Por mamen_mala

1 de clabLevel



 

unknown
Citar            
MensajeEscrito el 10 Jun 2004 05:35 pm
Pues que te digo, yo mismo lo probe reemplazando lso componentes de TextArea y TextInput por campos de texto estandar, y si le colocas el mismo nombre de instancia a ellos (donde dice "Instance Name", NO donde dice "var") funciona perfecto



Ahora claro, aqui tenemos en las FAQ porque damos solo ejemplos en MX2004 y no en MX

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 12 Jun 2004 04:27 pm
Hola me revisado 5000 mil veces los post q ponian y no e econtrado la respuesta q queria asi q voy a preguntar :(.



Wno Uso F MX 2004 y trato de hacer el tuto del mail.



He bajado el archivo q teneis en la web e modificado el codigo del mail.php quedando esto:



<?php

//direcion del correo donde a de llegar

$sendTo = "carter_xx@hotmail.com";

$subject = $_POST["asunto"];

$headers = "From: " . $_POST["Mi web"];

$headers .= "<" . $_POST["email"] . ">\r\n";

$headers .= "Reply-To: " . $_POST["email"];

$message = $_POST["cuerpo"];

mail($sendTo, $subject, $message, $headers);

echo "estado=Mensaje enviado :D";

?>





E subido los archivos index.html, email.swf, email.php a mi sirvidor iespana ( q en otro post e visto q si q funciona)



Entro a mi pagina le doy a enviar.... me dice... mensaje enviado!!!! Pero a mi correo no llega nada!!!!

Me pueden ayudar? GRACIAS!!

Por carter

14 de clabLevel



 

unknown
Citar            
MensajeEscrito el 12 Jun 2004 05:13 pm
Tienes que estar seguro que



a) Tienes soporte PHP en tu servidor

b) Tienes la función mail de PHP activada (En muchos hosting, sobre todo gratuitos, la desactivan)



Por ultimo, prueba con un formulario HTML que le envie al script PHP las mismas variables que Flash haber si asi si funciona

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 12 Jun 2004 05:57 pm
Wnas freddie en tu primer post dices miren estos hilos... yo lo e echo y e encotrado un post tuyo q dice :



"Iespana soporta PHP y tiene la función "mail" habilitada" y ese es el hosting q yo tengo. Por eso la a y la b no las e puesto.



y lo segundo q me dices no lo entiendo :( Sorry por mi torpeza

Por carter

14 de clabLevel



 

unknown
Citar            
MensajeEscrito el 13 Jun 2004 07:19 pm
Olla, tengo problemas con el envio del formulario. El principal problema es que no conozco el asp ni el php, y no se qué debo hacer con estos archivos.

Mi intento ha consistido en cambiar en ellos la dirección de email por la que yo quiero que sea la de destino, que es una cuenta de correo de ono (nombre@ono.com). Luego he subido el asp,el php

, el swf y el html a mi servidor (también el gratuito de ono) y no me va.

¿Me podeis ayudar?. Muchísimas gracias.

sandrujera [o-o]

Por sandrujera

8 de clabLevel



 

unknown
Citar            
MensajeEscrito el 13 Jun 2004 09:43 pm
Wno asi estamos todos :( asi q si alguien es tan amable podria decir algun hosting ( gratuito) en le cual tubiera la funcion del mail activada?Muchas gracias!

Por carter

14 de clabLevel



 

unknown
Citar            
MensajeEscrito el 14 Jun 2004 12:04 am
Creo que www.miarroba.com; y www.lycos.com



Lo unico que les puedo aseugrar es que por defecto el codigo que ofrecen los ejemplos funciona a la perfección; tendran que enviar un mail al webmaster de los hosting que tengan averiguando si esta habilitado o en ultimas instalarse Apache+PHP en sus computadiores para probar ;)



There's nothing like your 0wn server

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 14 Jun 2004 09:42 pm
Que hay freddy!



Mira, he estado probando el formulario de envio de mail, pero no lo he logrado.



Lo estoy probando en mi lugar de trabajo, en donde tienemos un servidor web propio (tenemos me sono a muchos "tienen"), he realizado el ejemplo, y ademas he descargado los archivos de ejemplo, yo elegí el ASP (tenemos el IIS en el server).



En el codigo de ASP tienes en el final,

%>

estado=Mensaje enviado :D



tienes lo de estado afuera del simbolo la etiqueta %>, y cuando lo corro asi, me sale, estado=undefined , y cuando lo pongo dentro de la etiqueta, me sale:

"Error en la aplicación de correo"



no se que pueda ser, lei en algunos de las mensajes que ya te han dejado, que les decias que revisaran si el servidor tiene activado lo de enviar correo, La verdad no se si el mio lo tenga, tenemos un windows 2000 server, ¿me puedes decir en que lugar le activo lo de correo?, o en caso de que sea otro mi error, ¿sabes cual es?



lo tengo en esta url:

www.tecnologicodeacuna.edu.mx/email/email.html



Espero puedas ayudarme!! :(

Por Sr. QUHO

SWAT Team

1643 de clabLevel

5 tutoriales
1 articulo

  SWAT

unknown
Citar            
MensajeEscrito el 14 Jun 2004 10:18 pm
tienes que tener activado un swervidor SMTP y configurado con el IIS; normalmente el mismo servidor SMTP de IIS sirve y se configura solo; pero debe estar activado y corriendo para funcionar

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 14 Jun 2004 10:37 pm
Si esta corriendo el SMTP en el servidor :?



No puedes mandarme un ejemplo que tu lo hayas probado y que funcione, para darme cuenta si en realidad sera mi server, o que estoy haciendo algo mal en los archivos.



quho@hotmail.com



esque tengo algunos dias intentandolo y no lo he logrado, y ya me desespere :(

Por Sr. QUHO

SWAT Team

1643 de clabLevel

5 tutoriales
1 articulo

  SWAT

unknown
Citar            
MensajeEscrito el 14 Jun 2004 11:24 pm
errr, el ejemplo que esta en la web yo mismo lo he probado y funciona ¬.¬

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 15 Jul 2004 10:22 am
perdón por mi ignorancia, pero no debería llamarse index o default.htm el principal del mail???

Por La100rra

Claber

5776 de clabLevel

11 tutoriales
4 articulos

Genero:Masculino  

Cd. Juárez, Chihuahua, México.

unknown
Citar            
MensajeEscrito el 16 Jul 2004 05:42 am
Hablas del archivo PHP que yo llamo "mail.php" (creo) en el tutorial que es el que recibe el formulario desde Flash y envia el correo?

NO

No es necesario; porque si no, se abrira de primeras y ese archivo ni siquiera debe ser visto por un navegador; solamente debe interactuar con Flash, asi que cualquier nombre aleatorio funciona

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 16 Jul 2004 11:27 am
okas, gracias! :)

Por La100rra

Claber

5776 de clabLevel

11 tutoriales
4 articulos

Genero:Masculino  

Cd. Juárez, Chihuahua, México.

unknown
Citar            
MensajeEscrito el 27 Jul 2004 08:26 am
He seguido este tutorial: http://www.cristalab.com/vertutorial.php?id=7

Y en la misma web donde esta el archivo de flash he incluido este codigo PHP:

Código :

<?php
$email = $_POST["email"] ;
$asunto = $_POST["asunto"] ;
$texto = $_POST["cuerpo"] ;
$para = "tu@direccion.com";
if(($nombre != "") && ($email != "") && ($asunto != "") && ($texto != "")) {
mail($para,$asunto,$texto,"From:Mi Web <$email>\r\nReply-To: $email\r\n");
echo "estado=Mensaje enviado correctamente";
}
?>


Y me funciona perfectamente.
Claro que cuando hize el flash cambie en el ActionScript, 'email.php' por el nombre de la web donde estaba el formulario flash y el codigo PHP:

Código :

envio_lv.sendAndLoad("email.php", recibir_lv, "POST");

se cambia por:

Código :

envio_lv.sendAndLoad("NombreDelArchivo.php", recibir_lv, "POST");


Yo uso un servidor de pago, a si que no puedo prometer que esto funcione en servidores gratuitos, de gratuitos yo he probado Mi Arroba y funciona.

Espero que esto os ayude en algo. ^^

Por [SkG]

10 de clabLevel



 

unknown
Citar            
MensajeEscrito el 13 Ago 2004 05:44 pm
Hola
Necesito saber si se puede envíar un formulario de flash por e-mail sin utilizar ninguna tecnología del servidor (no PHP, no ASP, etc) como se puede hacer en HTML (action=mailto:pepe@terra.es). Sólo quiero utilizar el cliente de correo de la persona que envía el formulario
Gracias
_________________
Tete Ferreiro

Por teteff

8 de clabLevel



 

unknown
Citar            
MensajeEscrito el 13 Ago 2004 06:14 pm

teteff escribió:

Hola
Necesito saber si se puede envíar un formulario de flash por e-mail sin utilizar ninguna tecnología del servidor (no PHP, no ASP, etc) como se puede hacer en HTML (action=mailto:pepe@terra.es). Sólo quiero utilizar el cliente de correo de la persona que envía el formulario
Gracias
_________________
Tete Ferreiro


Teteff, se paciente, esto no es un chat, no hay necesidad de postear la misma pregunta 3 veces
( primera 5:37 p.m. , segunda 5:43 p.m. , tercera 5:44 p.m. )


con respecto a tu pregunta, deberías leer todos los post de este mismo tema, creo que ahi dice muy claramente la respuesta a tu pregunta, :? creo yo.
en caso contrario, solo ten un poco de paciencia, nuestros "BOFH´s" deben tener mucho trabajo, pero ya te contestarán tus preguntas, no te desesperes, siempre lo hacen :wink:

Por La100rra

Claber

5776 de clabLevel

11 tutoriales
4 articulos

Genero:Masculino  

Cd. Juárez, Chihuahua, México.

unknown
Citar            
MensajeEscrito el 14 Ago 2004 03:01 am
BOFH right here

Puedes hacer en un boton un

Código :

getURL("mailto:cosa@cosa.com");


Pero es una practica bastante NO recomendada, ya que de un 100% un 1% sera efectivo y de ese 1% otro 1% enviara el correo

Ten en cuenta que la idea no es molestar a tu usuario; asi que de preferencia si no puedes usar lenguajes de servidor solo pon tu correo escrito

Por Freddie

BOFH

53 tutoriales
597 articulos
43 ejemplos

Genero:Masculino   Admin

Conserje de Cristalab

unknown
Citar            
MensajeEscrito el 14 Ago 2004 06:24 pm
Hola freddie®.

¿Entonces que es lo mas recomendable? Porque la mayoria de las páginas que andan en la web lo tienen de esa forma.
A ver, ya me pusiste a pensar ( milagro ) je je , creo que tienes razón, la gran mayoría está acostumbrada a mandar email desde "Llajú" o "hot Correo" y casi nadie usa el "ouchluq" que normalmente es el programa por default instalado en la mayoría de las computadoras, y mucha gente no sabe utilizarlo, o por ejemplo la gente que va a los chats públicos no tiene opción de mandarlo por esta vía, de tal forma que: ¿ Cómo se puede hacer para corregir esto ?
Pues incluyendo uno de los ejemplos de los tutoriales de Cristalab para envío de correo, verdad ?

¿ Es a eso que se debe el porcentaje tan bajo de exito que comentas ?

Por La100rra

Claber

5776 de clabLevel

11 tutoriales
4 articulos

Genero:Masculino  

Cd. Juárez, Chihuahua, México.

unknown
Ir a página 1, 2, 3, 4, 5, 6, 7, 8, 9  Siguiente
Foros de discusión > Actionscript 1 y 2

   Página 1 de 9

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.