Comunidad de diseño web y desarrollo en internet online

Ubuntu + wifi + WTF

Citar            
MensajeEscrito el 21 Abr 2008 01:43 am
Luego de tener una seria discusión con el virus XP (obviamente originario de un .torrent) he decidido instalar el ubuntu que misteriosamente vino a parar a mi casa presuntamente desde Holanda (no se si el pais o si es el nombre de la calle desde donde lo enviaron), pero en fin, el asunto es que una vez instalado, dañado y reinstalado mil y una vez no he podido conectarme a la $%&?¿!" red inalambrica de mi casa... :twisted:

El ubuntu presuntamente instala automaticamente los drivers para mi tarjetas (tanto la ethernet como la wireless, que dicho sea de paso es una D-Link DWL-G510), hasta ahi todo bien...


Aparentemente detecta las redes al alcance (incluyendo la red a la que me tengo que conectar) y ademas me indica la furza de las señales recibidas, etc, etc... :roll:

Hasta aqui parece que lo que estoy es perdiendo el tiempo escribiendo aqui ya que aparentemente todo está perfecto, pero NO, el problema en si es que aunque estoy "conectado" no tengo acceso a internet ni a la red ni nada de nada... que diablos podria ser.? :?

PD: mi grado de neofites en linux esta publicado bajo licencia gpl, por favor dejenme compartirla... :oops:

Por mauril26

161 de clabLevel



 

firefox
Citar            
MensajeEscrito el 21 Abr 2008 10:16 am
Hola,

Pues donde te sale lo de la señal de la red (las barritas de la fuerza) Dale a botón derecho e "Información de la conexión"

Ahí podrás ver algunos datos, en concreto tu IP, y tu DNS. Luego ve a la configuración del router, y mira si :

A.- Tienes filtrado de MAC
B.- Tienes servidor DHCP activado (la ip la otorga de forma automática) o desactivado (debes configurar la IP cuando te conectas)
C.- Tienes servidor DNS y coincide con el de la información de la conexión
D.- Si todo fuera correcto (y estás conectado a tu red, claro) puedes probar a buscar servidores DNS por internet (hay algunos muy buenos, mejor que los que te puedan dar en tu ISP) y configurarlo a mano en tu conexión

E.- Tu router/módem está conectado a internet. Si es por ADSL (línea telefónica) mira que está conectado y configurado. En el "Status" del router puedes ver si está caida la conexión o no. Si es por cable-modem resetea el router, a veces (depende del modelo y tal) se quedan atontaos.


Realmente es extraño, votaría por E, o por que realmente no estás conectado a ninguna red xDDDD

Por _CONEJO

BOFH

7639 de clabLevel

17 tutoriales
21 articulos

 

firefox
Citar            
MensajeEscrito el 21 Abr 2008 02:45 pm
Bueno, al menos en XP funciona bien... de hecho este post se envió a través de ese router. :lol:

A.- En fin, el router no tiene filtradas las MAC.
B.- El DHCP si está activo (aunq sin embargo yo utilizo IP's estáticas).
C.- Tengo servidor DNS y coincide con el de la información de la conexión.
D.- ---
E.- Seeeeeeeeeeeeeeeeeeh, si estoy "conectado"... Realmente al estar conectado al router aunque no hubiese internet deberia poder entrar al administrador del router y nop, nada que ver, por lo que asumo que no estoy ni conectado al router. :cry:

Como dato curioso puedo decir que en el administrador de dispositivos no aparece por ninguna parte la tarjeta de red inalambrica, solo aparece un dispositivo "unknown", pero se que es esa tarjeta por el driver que utiliza... aunque de todos modos hay muchos campos "desconocidos"...cabria la posibilidad de que aunque detecte las redes y sus fuerzas y aunque se """"conecte"""" pueda faltar el controlador adecuado.?

Alguna vez con el debian etch mi solucion fué instalar el ndiswrapper y utilizar los drivers diseñados para el XP, pero sobre el ubuntu no he podido hacer lo mismo, algo con el "Make" no me deja instalar el ndiswrapper...

Por mauril26

161 de clabLevel



 

firefox
Citar            
MensajeEscrito el 21 Abr 2008 03:13 pm
a mi al parecer algo similar me paso:

Estaba en la off buscando ingresar por ssh al servidor, desde andentro! y me encontraba en esas de nmap, ifconfig ssh -x -p ### root@miServer.com y todo este tipo de metodos desde mi laptop por medio de la wirles, hasta que en un momento plop se me jodi... la conexion wifi, con las mismas molestias que nombra maurikl26.

lo curioso es que si me puedo conectar a otro equipo con ssh pero a la web no veo ni mi...

Por jpcw

Claber

1715 de clabLevel

1 tutorial

Genero:Masculino  

AlgoritmicBrainDesigner

firefox
Citar            
MensajeEscrito el 21 Abr 2008 03:14 pm
La 7.10 de Ubuntu te instala un gestor de controladores restringidos y te suele instalar el correspondiente de tu tarjeta inalámbrica. (Sistema >> Administración >> Gestor de Controladores Restringidos, tiene que estar habilitado y "en uso")

Si no puedes ni acceder a la configuración del router es que efectivamente no estás conectado a la red. Abre una terminal y teclea "ifconfig" te deben de salir los dispositivos de red que tengas (eth0 eth1 ... quizás un ath0 ... depende de lo que tengas)

En terminal escribe "iwconfig" (si, con W en vez de F) para ver si realmente estás conectado, debería de salirte algo así :

Código :

lo        no wireless extensions.

eth0      no wireless extensions.

vmnet8    no wireless extensions.

eth1      IEEE 802.11g  ESSID:"NOMBRE_DE_LA_RED"  
          Mode:Managed  Frequency:2.442 GHz  Access Point: MAC_DEL_AP   
          Bit Rate:11 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=42/100  Signal level=-84 dBm  Noise level=-85 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:92276   Missed beacon:0


el ndiswrapper como los controladores (no todos, pero la mayoría) deben estar en los repositorios (en el CD de instalación si obviamente no tienes internet aún) Simplemente intenta instalarlos desde ahí. O pon el resultado del make, a ver si se puede sacar algo en claro.

Por _CONEJO

BOFH

7639 de clabLevel

17 tutoriales
21 articulos

 

firefox
Citar            
MensajeEscrito el 22 Abr 2008 03:40 am
Ok, probé el ifconfig y se trajó todos los dispositivos de red(incluyendo la wireless) y luego probé el iwconfig y si, se trae la data de la Dlink, incluyendo la red a la que estoy "conectado".

No entiendo porq diantres no tengo conexion, es mas hasta muestra la barrita con la intensidad de la señal (que dicho sea de paso ronda el 73%).

Alguna sugerencia.? :ownz:

Por mauril26

161 de clabLevel



 

firefox
Citar            
MensajeEscrito el 22 Abr 2008 04:52 am
1er wlan0 => iwconfig (ves, "detecta" la red, que se llama NETGEAR1)
2do wlan0 => ifconfig (el hardware existe como componente de red)
00:08.0 => lspci (el hardaware existe como elemento PCI)

ubuntu 7 escribió:

Código :

 wlan0     IEEE 802.11g  ESSID:"NETGEAR1"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0F:B5:21:4C:C4
          Retry limit:3   RTS thr:off   Fragment thr=2346 B
          Link Signal level=-67 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan0     Link encap:Ethernet  HWaddr 00:15:E9:3F:D9:A4
          UP DIFUSIÓN MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
          colisiones:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:5147 (5.0 KB)

00:08.0 Network controller [0280]: RaLink RT2561/RT61 rev B 802.11g [1814:0302] 

Por mauril26

161 de clabLevel



 

firefox
Citar            
MensajeEscrito el 22 Abr 2008 05:15 am
Pues a me estuvo dando algo de problemas la inalambrica en ubuntu, pero la logre hechar a andar con los drivers que trae el cd por defecto.

A veces me ha tocado reiniciar mi router para que pueda pegarme a la señal, y otras ha bastado con reconfigurar estaticamente la conexión.

igual que tu mi tarjeta es una dlink, pero no recuerdo el modelo ni lo tengo a la mano, aunque me parece que es el mismo tuyo; prueba con lo de reconfigurar la ocnexion, es decir, ponerla a cero y luego reconfigurar a los valores para que te pegues a la lan.

suerte...

Por Hg

33 de clabLevel



 

firefox
Citar            
MensajeEscrito el 24 Abr 2008 04:13 am
Ok, solución "rápida", instalar Debian (etch en mi caso) e instalar "ndiswrapper" para a su vez instalar los drivers propios del fabricante que trae el disco de la tarjeta específicamente los drivers diseñados para virus XP... y voilá... (y)

Por mauril26

161 de clabLevel



 

mozilla
Citar            
MensajeEscrito el 01 Nov 2018 10:52 pm
Revisando y encontrandome con este post de hace mucho tiempo, con ubuntu se tiene todo lo necesario para hackear wifi de una manera muy fácil y sencilla. Si tienes problemas con wifi, y cuentas con tu sistema operativo Ubuntu, la verdad que lo tienes fácil jeje. Saluditos

Por chwpro

0 de clabLevel



 

chrome

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.