Comunidad de diseño web y desarrollo en internet

visual studio 2008 y SQL

Citar            
MensajeEscrito el 25 Jul 2011 07:23 pm
Hola a todos:
Tengo una base de datos SQL 2005/2008 y quiero acceder a ella con una aplicacion visual studio 2008 (visual basic) a traves de un formulario, aparentemente no hay problemas, puedo navegar a traves de los registros pero no puedo ni agregar, editar y/o borrar registros.
Alguna solucion para este problema? Gracias

Por rla1965

3 de clabLevel



 

msie8
Citar            
MensajeEscrito el 26 Jul 2011 05:16 am
¿Qué permisos tiene el usuario que ingresa a la base de datos? ¿Cómo haces la autenticación de usuario?

Por nbreath

22 de clabLevel



Genero:Masculino  

chrome
Citar            
MensajeEscrito el 26 Jul 2011 01:45 pm

nbreath escribió:

¿Qué permisos tiene el usuario que ingresa a la base de datos? ¿Cómo haces la autenticación de usuario?
Los permisos para acceder a la base de datos SQL son a traves de la autenticacion de windows y en el formulario de visual basic no tengo nada que ofrezca o otorgue permisos para acceder a la base de datos.

Por rla1965

3 de clabLevel



 

msie8
Citar            
MensajeEscrito el 26 Jul 2011 04:18 pm
¿Y en la base de datos existe el usuario con el que te autenticas en windows? Es posible que que sus permisos solo sean de lectura mas no de modificación.

Por nbreath

22 de clabLevel



Genero:Masculino  

chrome
Citar            
MensajeEscrito el 26 Jul 2011 04:32 pm
Si, en la base de datos existe ese usuario.
Dejame explicarte algo. Cuando me refiero a que no puedo hacer nada con los registros, quiero decir que puedo visualizarlos en el formulario de la aplicacion visual basic, pero solo eso.
Cuando trato de hacer alguna operacion con los registors, no recibo ningun mensaje de error, pero no ocurre nada, el formulario acepta agregar un nuevo registro, pero cuando lo cierro y vuelvo a abrir no veo el registro que acabo de agregar unos segundos antes.

Por rla1965

3 de clabLevel



 

msie8
Citar            
MensajeEscrito el 27 Jul 2011 05:55 pm
Es muy extraño que no recibas algún mensaje, ¿haces la inserción de datos mediante instrucciones SQL o usas objetos como dataset, datable?

Por nbreath

22 de clabLevel



Genero:Masculino  

chrome
Citar            
MensajeEscrito el 05 Ago 2011 01:33 pm
Gracias por su ayuda nbreath, el formulario tenia un problema de diseño que ya resolvi, pero de cualquier manera las orientaciones/consejos que me dio sirvieron para dirigirme al lugar del problema. Gracias nuevamente.

Por rla1965

3 de clabLevel



 

msie8

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.