Comunidad de diseño web y desarrollo en internet online

WEBORB PHP y Flex

Citar            
MensajeEscrito el 01 Sep 2007 09:15 am
Hola.

No tengo instalado ningún web server en mi PC.
Estoy creando mi primera aplicación de test con WEBORB PHP.
He extraido la distribución de WEBORB en una carpeta de mi www root en un hosting remoto donde correrá esa ap.
La guía de inicio de WEBORB pone un ejemplo configurando el nuevo proyecto Flex para que use WEBORB en localhost, caso que no es el mío:

1. ¿Es imprescindible tener web server en local para programar Flex con WEBORB?

2. ¿Cómo debo configurar el nuevo proyecto Flex (roots, URLs, etc...) para trabajar con WEBORB alojado en hosting remoto? (pensando que ejecutaré la ap en el mismo servidor alojado en remoto)

3. ¿Dónde está el panel de servicios del que habla la doc de WEBORB en la consola?


1000 gracias

Montse

Por montse

6 de clabLevel



 

firefox
Citar            
MensajeEscrito el 03 Sep 2007 10:38 pm
1.- Si, es totalmente necesario disponer de tu servidor local, ya que Flex requiere enlazar de manera estática con Weborb en compilación, y para ello la carpeta donde están los ficheros de configuración de Weborb, deben ser accesibles a nivel de disco local para ello.

2.- Una vez has desarrollado tu aplicación y la tienes compilada, subes al sitio tu swf resultado de la compilación, y depositas en la carpeta Services, tus servicios propios.

3.- http://{tudominio}/Weborb/ pero solo dispondrás de ella si tienes instalado WebORB 2.0x

Nota.: Recuerda que tanto la carpeta Weborb como la carpeta Services, han de alojarse en el raiz de tu sitio /

Por MorphX

SWAT Team

982 de clabLevel

3 tutoriales

  SWAT

La Telaraña Digital

firefox
Citar            
MensajeEscrito el 04 Sep 2007 08:37 am
Gracias Morfx.

Seguiré esos pasos.

De todas formas, he detectado otro problema al respecto.

Cuando añado (o añade el wizard de creación de proyecto de FB) algun argumento a la linea "additional compiler options" en flex builder, no compila. Me queda la carpeta bin vacía. Cuando quito la opción -services sí que genera automáticamente los archivos en bin.

¿Alguna idea?

Gracias por tu amabilidad.

Montse

Por montse

6 de clabLevel



 

firefox
Citar            
MensajeEscrito el 05 Sep 2007 08:49 am
Seguramente tengas un problema de ruta hacia tu Weborb local, pues la lineas que comentas, es necesaria para poder usar FDS, y por lo tanto Weborb.

Revisa que la ruta sea válida, y que el proyecto esté en modo FDS con compilación LOCAL.

Por MorphX

SWAT Team

982 de clabLevel

3 tutoriales

  SWAT

La Telaraña Digital

firefox
Citar            
MensajeEscrito el 05 Sep 2007 08:53 am
Usé la solución más informática.

Reinstalé FB y funcionó.

Gracias

Por montse

6 de clabLevel



 

firefox
Citar            
MensajeEscrito el 11 Sep 2007 10:24 am
Bueno.

Instalé wamp en mi PC y weborb funcionó OK.

Ahora intento subir la aplicación a un host remoto donde estará alojada finalmente.

¿Cómo instalo allí WEBORB?

He creado una carpeta llamada "weborb" en la raíz www del server remoto y he copiado el contenido del zip de instalación de weborb allí.
He subido mis php a la carpeta "services" y he copiado mi "remoting-config.xml" con mis "destinations" a la carpeta flex.
He creado otra carpeta para la aplicación y la he desplegado allí, incluído el archivo weborb.php que apunta al localhost correspondiente.

Mi aplicación no encuentra el servicio.

No sólo eso. La consola de weborb no muestra la pestaña "management" y sus ejemplos me dan "send failed".

¿Debo hacer algo más? :?

Estoy desesperada! (parece un consultorio sentimental) :)

1000 gracias de nuevo

Montse

Por montse

6 de clabLevel



 

firefox
Citar            
MensajeEscrito el 11 Sep 2007 11:30 pm
Aunque supongo que puede ser por como has posteado, de todos modos insisto ya que es un fallo común.

La ruta a de ser:

http://{tudominio}/Weborb
http://{tudominio}/Services

Es decir, nota las Mayusculas iniciales, y recuerda que los hosting con PHP suelen correr en Linux, por lo tanto las Mayusculas INFLUYEN!! tanto en carpetas, como en los nombres de las tablas de la BD (pq en realidas son ficheros luego ;) )

De tu post, no puedo deducir a priori nada más... ya nos cuentas :)

Por MorphX

SWAT Team

982 de clabLevel

3 tutoriales

  SWAT

La Telaraña Digital

firefox
Citar            
MensajeEscrito el 25 Ago 2009 06:24 am
a ver yo presento un problema similar y necesito sacarme las dudas urgente.
hice lo siguiente.logre configurar mi weborb,subirlo y que vea el archivo .php, lo que hice fue agregar esto

Código XML :

 </destination>
     <destination id="prueba1">
       <properties>
       <source>prueba1</source>
       </properties>
</service> --> fin del archivo no agregar
       </destination>

al final del archivo remoting-config y listo,aloje mi php en service dentro de la carpeta weborb.y andubo sin problemas
lo que pasa ahora es que necesito modificar flex para que vea el service config en el servidor y no se como hacerlo
explico
en proyect --> properties --> flex compiler y puse mi ruta por defecto para el service config que es esta
-locale en_US -services L:\AppServ\www\wophp\Weborb\WEB-INF\flex\services-config.xml

pero ahora la tengo que subir a mi sitio y tengo que modificarla y mi sitio empieza con /public_html/ ... y hay va weborb dentro
les paso el ejemplo que hice y todo el codigo y me dicen que modifico o que hago si??

Código Flex :

<?xml version="1.0" encoding="utf-8"?>
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute" creationComplete="init()">
   <mx:RemoteObject id="remoteObject"
        destination="GenericDestination"
        source="prueba2"
        showBusyCursor="true"
        fault="onFault(event)">
        <mx:method name="obteneDato" result="obtenerDato_Result(event)"/>
        </mx:RemoteObject>
        
        <mx:RemoteObject id="remoteObject1"
        destination="GenericDestination"
        source="prueba2"
        showBusyCursor="true"
        fault="onFault(event)">
        <mx:method name="obtenerEmpresa" result="obtenerEmpresa_Result(event)"/>
        </mx:RemoteObject>
   <mx:Button x="84" y="114" label="boton2" click="obtener()"/>
   <mx:TextInput x="215" y="114" id="txtnombre"/>
   <mx:Script>
      <![CDATA[
         import mx.rpc.events.ResultEvent;
         import mx.rpc.events.FaultEvent;
          import mx.rpc.*;
          import mx.collections.ArrayCollection;
          import mx.controls.Alert;
        
          public function init():void{
          remoteObject1.obtenerEmpresa();
          }
          public function obtener():void{
          remoteObject.obteneDato();
          }
          public function onFault(event:FaultEvent):void{
               Alert.show(event.fault.faultString,"error");
          }   
          public function obtenerDato_Result(event:ResultEvent):void{
          txtnombre.text = event.result as String;        
          }
          public function obtenerEmpresa_Result(event:Object):void{
          var cadena:Array = event.result as Array;
          myDG.dataProvider =  cadena;
          txtnombre.text = cadena[1].empresas; // para elegir solo 1 elemento        
          }        
      ]]>
   </mx:Script>
   <mx:DataGrid x="170" y="162" id="myDG">
      <mx:columns>
         <mx:DataGridColumn headerText="empres" dataField="empresas"/>
         <mx:DataGridColumn headerText="Column 2" dataField="id"/>
      </mx:columns>
   </mx:DataGrid>
</mx:Application>


y si lo subo como esta,me da un error,y si largo el service config en la carpeta,me dice que no encuentra el channel para genericdestination,ayuda por dios!!!!

Por viru2k

20 de clabLevel



 

firefox
Citar            
MensajeEscrito el 25 Ago 2009 06:37 am
Revisa la sintaxis de tu service-config.xml, y asegurate de indicar un canal para remoting que haga referencia al protocolo amf, indicando como url la ruta publica de tu weborb.php.
Luego revisa tu fichero remoting-config.xml y asegurate de que has declarado un servicio a tal efecto para que pueda ser referenciado por tus RPC's desde Flex.

En cuanto a la línea del compilador "-locale en_US -services L:\AppServ\www\wophp\Weborb\WEB-INF\flex\services-config.xml" es solo para eso, para compilar, es la manera que usas para indicar a Flex como ha de construir el swf para luego encontrar los servicios que en ese fichero le indicas en compilación, no alteres esa linea con datos de tu servidor, pues no tiene nada que ver.

Un saludo.

Por MorphX

SWAT Team

982 de clabLevel

3 tutoriales

  SWAT

La Telaraña Digital

firefox
Citar            
MensajeEscrito el 26 Ago 2009 05:10 am
bueno, respondo,ya que al rato de postear le logre encontrar la vuelta, en vez de poner toda la direccion solamente puse
-services "services-config.xml" y cuarde mi archivo service config en el raiz de src, donde esta la main aplicacion. y le cambie el path que decia weborb
aqui les dejo el codigo para que lo copien tal cual,sobreescribanlo sobre lo que ya viene del service config por defecto

Código XML :

<?xml version="1.0" encoding="UTF-8"?>
<services-config>

  <services>
    <service id="amfphp-flashremoting-service"
        class="flex.messaging.services.RemotingService"
        messageTypes="flex.messaging.messages.RemotingMessage">
      <destination id="GenericDestination">
        <channels>
          <channel ref="my-amf"/>
        </channels>
        <properties>
          <source>*</source>
        </properties>
      </destination>
    </service>
  </services>

  <channels>
    <channel-definition id="my-amf" class="mx.messaging.channels.AMFChannel">
      <endpoint uri="http://diseniosoft.com.ar//wophp/Weborb/index.php"  --->ESO ES DONDE TIENEN QUE MODIFICAR Y PONER SU DIRECCION ,BORREN ESTE TEXTO QUE PONGO EN MAYUSCULAS class="flex.messaging.endpoints.AMFEndpoint"/>
    </channel-definition>
    
  </channels>

</services-config>


y listo,hay quedo configurado mi front-end o sea la parte local de la aplicacion

Por viru2k

20 de clabLevel



 

firefox

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.