Comunidad de diseño web y desarrollo en internet online

deberia poner mensaje enviado y pone [b]undefined [/b]

Citar            
MensajeEscrito el 24 Ago 2005 09:24 am
acabo de realizar el tutorial enviar mensaje usando loadvars
y todo me funciona bien bien recibo el mensaje pero en el campo
estado deberia poner mensaje enviado y pone undefined
me podeis decir porque?
gracias

Por parotet

1 de clabLevel



Genero:Masculino  

msie
Citar            
MensajeEscrito el 24 Ago 2005 09:32 am
os envio el vinculo donde esta la aplicación para que vais lo que pasa.

http://www.e-motivo.net/email.html

Por parotet

1 de clabLevel



Genero:Masculino  

msie
Citar            
MensajeEscrito el 24 Ago 2005 02:55 pm
Y si mejor pones el codigo que utilizas para envia las variables al Script... para darnos una mejor idea

Por Tmeister

260 de clabLevel

2 tutoriales

 

firefox
Citar            
MensajeEscrito el 25 Ago 2005 12:12 am
Hola!
a mi también me pone undefined pero no me llega nada al mail que le puse como ruta...

help!

Por zuli

19 de clabLevel



Genero:Femenino  

msie
Citar            
MensajeEscrito el 25 Ago 2005 12:31 am
ok zuli, leite el post de Tmeister, pueden ser muchas razones del error, si publican su código seria mas fácil ayudarlos, aunque en el foro ya se ha tratado ese tema muchisimo, si quieres realiza una busqueda :D

Por Maikel

BOFH

5575 de clabLevel

22 tutoriales
5 articulos

Genero:Masculino   Team Cristalab

Claber de baja indefinida

firefox
Citar            
MensajeEscrito el 25 Ago 2005 12:38 am
Hola Maikel,
no pongo el código porque descargo el ejemplo y este es el que me pone undefined, no se si es porque en php pongo:

<?php
$sendTo = "[email protected]";
$subject = $_POST["asunto"];
$headers = "From: " . $_POST["Cristalab_Flashform"];
$headers .= "<" . $_POST["email"] . ">\r\n";
$headers .= "Reply-To: " . $_POST["email"];
$message = $_POST["cuerpo"];
mail($sendTo, $subject, $message, $headers);
echo "estado=Mensaje enviado :D";
?>

Por zuli

19 de clabLevel



Genero:Femenino  

msie
Citar            
MensajeEscrito el 25 Ago 2005 12:49 am

Código :

 echo "&estado=Mensaje enviado Muy Feliz";


ponle el & a ver que tal?

ahora con respecto a que te no llega el mail, estas segura que php de tu servidor tiene la funcion mail habilitada? :?

haz un prueba, con php solamente.

Código :

<?php
$sendTo = "[email protected]";
//$subject = $_POST["asunto"];
$subject = "prueba de la funcion mail";
//$headers = "From: " . $_POST["Cristalab_Flashform"];
$headers = "From: mi propio script";
//$headers .= "<" . $_POST["email"] . ">\r\n";
$headers .= "<ponunmailaqui>\r\n"
//$headers .= "Reply-To: " . $_POST["email"];
$headers .= "Reply-To: elmailquepusistearriba";
//$message = $_POST["cuerpo"];
$message = "Haciendo una prueba con php para enviar un mail";
mail($sendTo, $subject, $message, $headers);
echo "estado=Mensaje enviado Muy Feliz";
?>

copia ese codigo y ejecutalo a ver si te funciona la funcion mail :wink:

cualquier cosa avisanos :D

Por Maikel

BOFH

5575 de clabLevel

22 tutoriales
5 articulos

Genero:Masculino   Team Cristalab

Claber de baja indefinida

firefox
Citar            
MensajeEscrito el 25 Ago 2005 02:12 am

zuli escribió:

<?php
$sendTo = "[email protected]";
$subject = $_POST["asunto"];
$headers = "From: " . $_POST["Cristalab_Flashform"];
$headers .= "<" . $_POST["email"] . ">\r\n";
$headers .= "Reply-To: " . $_POST["email"];
$message = $_POST["cuerpo"];
mail($sendTo, $subject, $message, $headers);
echo "estado=Mensaje enviado :D";
?>
[/quote]

Si no mal entiendo es porque estás tratando de enviar un email a un servidor fuera de donde está montado el formulario, deberías crear una cuenta en tu servidor y de ahí redireccionas a la dirección de gmail, al menos eso es lo que yo hago, pero te repito, no creo que te envíe nada si el dominio de la dirección de email no es la misma que la del dominio donde se encuentra el formulario.

:wink:

Por La100rra

Claber

5776 de clabLevel

11 tutoriales
4 articulos

Genero:Masculino  

Cd. Juárez, Chihuahua, México.

clabbrowser
Citar            
MensajeEscrito el 25 Ago 2005 02:16 am
eehhhhh disculpa La100rra si lo envia :)

Por Maikel

BOFH

5575 de clabLevel

22 tutoriales
5 articulos

Genero:Masculino   Team Cristalab

Claber de baja indefinida

firefox
Citar            
MensajeEscrito el 25 Ago 2005 08:20 pm
WTF?

Yo lo intenté muchas veces y nada, de forma que hice lo que comenté anteriormente.

Juas!. :lol:

Por La100rra

Claber

5776 de clabLevel

11 tutoriales
4 articulos

Genero:Masculino  

Cd. Juárez, Chihuahua, México.

clabbrowser

   Página 1 de 1

 

Cristalab BabyBlue v4 + V4 © 2011 Cristalab
Powered by ClabEngines v4, HTML5, love and ponies.